Geo Struct Sparks LLC

When Mononobe-Okabe Equation Doesn't Work

Blog

Mandatory Upgrade March 2012

Posted on March 28, 2012 at 8:30 AM

In the first released version of the program in March 2010, we included a mandatory upgrade feature where the program, either in demo mode or with a license, stopped working 2 years after last compiled.  When the progam is opened, the "About" screen opens but there is a message in red "Suggesting" that the user go to this website and download a new version.  Rather than continue to the main program, the program closes after this screen.  This was to make certain that we could correct any bugs or make improvements if necessary and require everyone to upgrade to a new version with those changes.


This seemed like a good idea at the time (sorry!), but frankly I forgot about this until after the program lapsed this March.  (Meanwhile I had switched computers and did not have the compiler installed, so it took a week to catch up, etc...).  For users of either demo or licensed copies, thd fix is simple:  download the new version and install it over the old version.  I have found that it is not necessary to uninstall the old version before installing the upgrade.


The following changes were made to the new program version:

The license expiration counter (number of days left on license) counted up rather than down, although the license did correctly expire after a year;

We added a second equation to the Franklin and Chang upper bound displacement model applicable if the design Kh is much lower than the earthquake acceleration (see parameter guide);

The program will still suggest that you upgrade in two years time, but it will continue running.



Categories: None

Post a Comment

Oops!

Oops, you forgot something.

Oops!

The words you entered did not match the given text. Please try again.

Already a member? Sign In

0 Comments